首页 > 上网技巧 > 电脑小技巧 > 正文

解决php5.4自带的php-fpm无法启动的参数配置

时间:2013-01-28 20:01 作者:QQ地带 我要评论

新版PHP5.4安装完后,自带的php-fpm无法启动
1、修改配置文件php-fpm.conf文件,启用以下两项
pid = run/php-fpm.pid
error_log = log/php-fpm.log
 
启用的原因是因为使用PHP5.4自带的php-fpm的系统启动脚本时,它全自己建立一个php-fpm.pid的文件,但是php-fpm配置文件里默认是不会启用这个选项的,在使用这个脚本时,会无法关掉php-fpm的进程。
如果是使用命令行启动php-fpm的话,则可无视上面的内容。

标签:php php-fpm
顶一下
(0)
0%
踩一下
(0)
0%

Google提供的广告