首页 > 上网技巧 > 电脑小技巧 > linux CentOS下安装word2vec教程

linux CentOS下安装word2vec教程

时间:2014-11-07 10:43 作者:QQ地带 我要评论

关于google的word2vec项目,这里就不用介绍了,接下来需要很干货的分享给大伙,在CentOS下安装word2vec的linux教程。关于如何在各个linux操作系统上安装word2vec,google的word2vec项目首页并未过多讲,或是详细的描述安装的linux教程。
word2vec项目的官网上,只有这么几段简短的关于使用的描述和linux教程:
Quick start
Download the code: svn checkout http://word2vec.googlecode.com/svn/trunk/
Run ‘make’ to compile word2vec tool
Run the demo scripts: ./demo-word.sh and ./demo-phrases.sh
For questions about the toolkit, see http://groups.google.com/group/word2vec-toolkit
详细的安装word2vec项目的linux如下:
当然,如上所说,该操作是在CentOS系统下的。
1、确保gcc为最新版
 
  1. yum install gcc 
2、安装subversion,用来获取word2vec源码
 
  1. yum install subversion 
3、指定一个任意目录为word2vec工作目录,通过svn指令获取word2vec源码
 
  1. svn checkout http://word2vec.googlecode.com/svn/trunk/ 
4、使用make指令进行安装
 
  1. make 
可以发现在安装的时候,会出现如下error:
 
  1. gcc word2vec.c -o word2vec -lm -pthread -Ofast -march=native -Wall -funroll-loops -Wno-unused-result 
  2. cc1: error: invalid option argument ?Ofast? 
  3. cc1: warning: unrecognized command line option “-Wno-unused-result” 
  4. make: *** [word2vec] Error 1 
这是因为该系统的gcc不支持Ofast选项的原因。
5、编辑makefile文件,更改gcc安装选项
 
  1. vi ./makefile 
word2vec的makefile源码如下:
 
 
  1. CC = gcc 
  2. #The -Ofast might not work with older versions of gcc; in that case, use -O2 
  3. CFLAGS = -lm -pthread -Ofast -march=native -Wall -funroll-loops -Wno-unused-result 
  4.   
  5. all: word2vec word2phrase distance word-analogy compute-accuracy 
  6.   
  7. word2vec : word2vec.c 
  8.  $(CC) word2vec.c -o word2vec $(CFLAGS) 
  9. word2phrase : word2phrase.c 
  10.  $(CC) word2phrase.c -o word2phrase $(CFLAGS) 
  11. distance : distance.c 
  12.  $(CC) distance.c -o distance $(CFLAGS) 
  13. word-analogy : word-analogy.c 
  14.  $(CC) word-analogy.c -o word-analogy $(CFLAGS) 
  15. compute-accuracy : compute-accuracy.c 
  16.  $(CC) compute-accuracy.c -o compute-accuracy $(CFLAGS) 
  17.  chmod +x *.sh 
  18.   
  19. clean: 
  20.  rm -rf word2vec word2phrase distance word-analogy compute-accuracy 
注意观察,第二行:
#The -Ofast might not work with older versions of gcc; in that case, use -O2
google的工程师这里有写到相关注意事项,告诉开发者,-Ofast安装选项,可能对于旧版本的gcc不支持,如果在这种情况下,需要将-Ofast改为-O2
所以将第三行
CFLAGS = -lm -pthread -Ofast -march=native -Wall -funroll-loops -Wno-unused-result
更改为
CFLAGS = -lm -pthread -O2-march=native -Wall -funroll-loops -Wno-unused-result
6、使用make指令安装通过
 
  1. make 
 
安装通过后的内容为:
gcc word2vec.c -o word2vec -lm -pthread -O2 -march=native -Wall -funroll-loops -Wno-unused-result
gcc word2phrase.c -o word2phrase -lm -pthread -O2 -march=native -Wall -funroll-loops -Wno-unused-result
gcc distance.c -o distance -lm -pthread -O2 -march=native -Wall -funroll-loops -Wno-unused-result
gcc word-analogy.c -o word-analogy -lm -pthread -O2 -march=native -Wall -funroll-loops -Wno-unused-result
gcc compute-accuracy.c -o compute-accuracy -lm -pthread -O2 -march=native -Wall -funroll-loops -Wno-unused-result
chmod +x *.sh
关于CentOS下安装word2vec的linux教程介绍到此,应该没有问题,亲自尝试后,通过。

标签: centos
顶一下
(0)
0%
踩一下
(0)
0%

Google提供的广告